Issue Type: Improvement Improvement
Assignee: Unassigned
Components: api
Created: 04/Dec/12 7:41 AM
Description:

Currently method parameter constraints are denoted using @CrossParameterConstraint when a constraint is defined.

I propose that method parameter constraints are "normal" constraints and the application to method parameters is denoted when the constraint is declared on a method:

@ParameterTuple(@EqualPasswords)
public void register(String username, String password, String confirmPassword) {

}

I also propose a name more based on programming language terms (e.g. @ParameterTuple) than usage terms (@CrossParameterConstraint).

Project: Bean Validation
Priority: Major Major
Reporter: George Sapountzis
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira