@Radim, etal... Given the switch in paradigm to have Session generate/keep just the one "CacheTransactionContext", what do you think about renaming that to CacheTransactionObserver? That seems to better describe this new paradigm.