Emmanuel Bernard commented on Bug OGM-208

Specifically about the programmatic API, Sanne recommends to not get global mapping interface to be extended by entity / property level interfaces to make things easier to read for users

mapping
    .defaultQuorum( 1, 2 )
    .entity(Example.class)
        .entityQuorum( 1, 3 )
     .entity(Sample.class)
     .entityQuorum( 1, 4 )


mapping
    .defaultQuorum( 1, 2 )
    .entity(Example.class)
        .entityQuorum( 1, 3 )
     .entity(Sample.class)
     .entityQuorum( 1, 4 )
        .defaultQuorum( 1, 2 ) //NOT COMPILE
mapping
    .entity(Example.class)
        .entityQuorum( 1, 3 )
    .entity(Sample.class)
        .entityQuorum( 1, 4 )
    .globalOptions()
        .defaultQuorum( 1, 2 )

I agree with the idea

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators.
For more information on JIRA, see: http://www.atlassian.com/software/jira