|
I started my work here: https://github.com/openwide-java/hibernate-search/commits/HSEARCH-1392
I already fixed a couple of problems and enabled the enforcer DependencyConvergence rule, except for the hibernate-search-integrationtest-as module which has a *lot* of dependency issues and it will be a real pain to maintain a dependencyManagement for all these problems.
I removed a couple of properties I shouldn't have removed as they are used in the modules. I kept my commits as is as I think it's interesting for the next one to see they shouldn't be removed - and I also added comments to prevent it.
What I would like to do now:
Cleaning up: - Reorganize the properties and the dependencies to be a bit more logical: especially group Hibernate / Lucene / Test dependencies. - Add the properties for the dependencies used in integration tests in the parent pom. I don't think it's a good idea to move the dependencyManagement in the parent pom but the versions would be a good reminder. The fact that they are really outdated is a good sign that they have been forgotten. - Be consistent for the property naming convention: it's not consistent between the parent pom and the integration tests (commonsCodecVersion, version.jboss.as, spring-release-version). I personnaly favor something like ${commons-codec.version} (${artifact-id.version}) and for the integration tests, I would have gone with ${integration-as.jboss-as.version}, ${integration-spring.spring.version}.
Dependency upgrade:
- Upgrade slf4j to the latest 1.6.x (1.6.6). We are currently using 1.6.1 which is needed by Solr but Avro already requires 1.6.4. - Upgrade Tika to 1.4: AFAICS, it's only used by Hibernate Search directly, not by its dependencies. It's usually a good idea to upgrade Tika as there are often a lot of fixes on the filters. It might be a good idea to create a specific issue for this one to have it in the changelog? - Upgrade all the test dependencies. - Upgrade Avro to 1.7.3? Looks like the upgrade is painless. I don't have any compilation error. But maybe it's still in 1.6 to be consistent with other components of the JBoss stack? This one is probably more 5.0 material as it touches the clustering part which is probably harder to test.
Feedback welcome.
|
|
|
|
|