| I can't speak to the overall premise of relying on class names - we all agree that is a bad practice. However, making them as readily recognizable as possible is, imo also, a good plan. To that end, I'd actually recommend a better solution -
- Deprecate the old naming - DeprecationLogger - refer to the new setting and document the change in behavior in 6.0
- Add a setting to switch between naming patterns
- Have the BytecodeProvider consider this new setting when building names.
And actually to facilitate (3) I'd probably make this a helper/delegate we pass into the BytecodeProvider to consistently apply this behavior |