> Thanks for the input – changes were made as suggested. If you have a sec to check the commit and let me know if I missed anything, I'd appreciate it!

Had a look at the code. Here are some comments (btw, it would be better to create pull requests and discuss code there. This way we get a chance to make changes before they get committed).

  • It seems you are ordering imports differently. Might be strict alphabetical. However, we generally sort hibernate imports last (just noticed looking at the diff)
  • MetadtaSources looks good
  • Nice cleanup in ConfiguredClass#createMappedAttribute. Regarding ConfiguredClass#determineAttributeNature, I probably would have split the method now. It gets a bit too long. One might also consider moving line 603 - 622 last, so that we first check for existing annotations and if there is none we do one final check on whether the referenced type as an annotation.
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira