| So to wrap up (no pun intended), this is what should be done:
- find a better name for validateUnwrappedValue()
- add unwrap(Class) allowing providers to define extensions to ConstraintDescriptor with additional methods
- in HV, if there's demand, add such extension with a method getEffectivelyApplyingUnwrapConfiguration()
|