Agree with "idFetchSize". As for "entityFetchSize", I prefer "partitionFetchSize": I don't like "entityFetchSize" because "entity" has a special meaning in our JSR-325 implementation, it means entity level. Here's the list of all the levels:
- Job level: the highest level. It means a job-execution, which consists several entity types to index
- Entity level: the 2nd level. It means the resources dedicated to index the given entity type: an entity-level progress monitor, and a set of partitions for indexing the entities of this entity type
- Partition level: the 3rd level. A partition indexes a subset of entities of a given entity type.
- Chunk level: the lowest level. Items processed between checkpoints are referred to as a "chunk". (ยง8.2.1 Chunk, Spec 1.0)
I think "partitionFetchSize" is more preferable here. |