This didn't help unfortunately.

But I got a bit further. There seems to be a dependency between NegativeValidationTestCase and DisabledValidationTestCase (in the same package). If I run the former alone, it fails, but if I run the two together via -Dtest..., both pass.

I really can't say what's causing this: NegativeValidationTestCase just expects *any* exception (@Test(expected = Exception.class)), so it's really hard to say what's actually asserted here. I guess DisabledValidationTestCase creates some exceptional state which then causes NegativeValidationTestCase to pass, though possibly not due to the exception originally expected.

2013/4/19 Scott Marlow <>
You might need to define allTests.  Something like this might work better:

cd testsuite/integration/basic/

mvn install -Dts.noSmoke -DallTests

Could you try again like this (after building AS8 first).

On 04/18/2013 12:29 PM, Gunnar Morling wrote:
Hi all,

I'm having a problem with running single tests on jboss-as/master.

If I run all the "basic" integration tests (via ./
test -Dts.basic), everything works fine. But if when I run a certain
test only (/ test -Dts.basic
-Dtest=NegativeValidationTestCase), that one will fail.

The log says:

org.jboss.msc.service.DuplicateServiceException: Service is already

(See for the complete stack trace). IIUC
this factory is registered by this test itself, but somehow it fails to
be properly removed/cleaned up when only this single test is run.

Does anyone have an idea what's the cause for this and how it can be

Thanks a lot,


jboss-as7-dev mailing list