On Jan 20, 2012, at 1:26 AM, jean-frederic clere wrote:

That isn't an error in httpd configuration, but probably in the connector of the web subsystem in AS7.

Mail me all the files I will have a look later.

I've tried to reconfigure all things again and the problem get solved! I guess the problem is caused by different 'port-offset' in 'socket-bindings' settings in host.xml between master and slave.

There was a typo in port-offset of master, so I guess mod_cluster is try to use the offset setting in master, and when it's trying to use the same offset to connect to slave, it throws error. But it's really weird it say cannot connect to 'localhost' instead of the ip address of slave.

Anyway, the cluster works now! Thank you for help Jean-Frederic :-)

Success Log: 

[Server:server-three] 02:21:43,139 INFO  [org.infinispan.remoting.transport.jgroups.JGroupsTransport] (Incoming-4,null) ISPN000094: Received new cluster view: [server-three/web|1] [server-three/web, server-three-slave/web]

Now there's another question: How can I configure mod_cluster to use round-robin to distribute requests?

I've tried to access cluster with different computers/browsers, but it seems all the requests are direct to master. Can I configure this in domain.xml?



- Weinan Li
JBoss, Redhat