JBoss Community

Stuck in BRMS

created by starfish15 in JBoss ESB Development - View the full discussion

Hello every1,



I am doing the needful with the BRMS after coding and learning JBoss ESB. However i am stuck terribly in the same. I did the following


  • Unzipped the brms-deployable-5.1.0.zip
  • Next unzipped the jboss-brms-manager
  • Placed the jboss-brms.war at D:\JBoss SOA\jboss-soa-p.5.0.0\jboss-as\server\default\deploy\
  • In the properties-service.xml file, added drools.serialization.sign=false at attribute Properties like mentioned below    

          <attribute name="Properties">



  • Next at D:\JBoss SOA\jboss-soa-p.5.0.0\jboss-as\server\default\deploy\jboss-brms.war\WEB-INF, added the following in components.

          <security:role-based-permission-resolver enable-role-based-authorization="true"/>

  • Then on a web browser tried hitting http://localhost:8080/jboss-brms/
  • The Login Page asking the User Name and Password came up
  • Tried logging in using admin/admin for both
  • Pop -Up saying incorrect username and password came up.


Also someone told me to do this "uncomment the user and roles settings in the configuration. Check the conf/props and open the brms-users.properties and brms-groups.properties files." Now the catch is i am unable to find both these files absolutely anywhere within the server folder in jboss-as of jboss-soa-p.5.0.0.


Kinldy assist at the earliest and do let me know if i am mistaken absolutely anywhere.




Reply to this message by going to Community

Start a new discussion in JBoss ESB Development at Community