JBoss Community

How do I install jBPM into jBOSS 7.1 (Windows)?

created by Al Koch in jBPM - View the full discussion



I have used the jBPM Installer Full to get some familiarity with jBPM and I now need to install JBoss and jBPM on a "production" system.  That means I need just these two items and none of the other "demo" items installed by the Full Installer.


I installed (under Windows 7) JBoss 7.1.1 by downloading jboss-as-7.1.1.Final.zip from http://www.jboss.org/jbossas/downloads/ and then unzipped jboss-as-7.1.1.Final.zip to get the jboss-as-7.1.1.Final folder which I placed under C:\Program Files.  I can launch the server with standalone.bat and I am able to access the Management Console so all indications are that it is running.  (The "DOS Box" console shows no errors as well.)


I have tried to deploy jBMP in a couple of different ways:

1) With the server shutdown, I copied the six .war files (designer.war, drools-guvnor.war, jbpm-form-builder.war, jbpm-gwt-console.war, jbpm-gwt-console-server.war and jbpm-human-task-war.war) from the .\standalone\deployments folder that was created buy the Full Installer and placed them in the same folder of the new JBoss installation.  I then launched JBoss and the console showed numerous errors as it detected and tried to deploy each .war.  Once the "deployment process" completed the jBPM server was not running.

2) I downloaded jbpm-5.4.0.Final-gwt-console.zip from http://sourceforge.net/projects/jbpm/files/jBPM%205/jbpm-5.4.0.Final/.  As above, I placed jbpm-gwt-console-server-5.4.0.Final-EE6.war in the .\standalone\deployments folder and started JBoss.  I again got numerous errors which started with:

12:57:06,500 INFO  [org.jboss.as.connector.subsystems.datasources] (MSC servicethread 1-1) JBAS010400: Bound data source [java:jboss/datasources/ExampleDS]

12:57:06,516 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-4) JBAS015876: Starting deployment of "jbpm-gwt-console-server-5.4.0.Final-EE6.war"

12:57:14,157 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-2) Class Path entry jaxb-api.jar in "/C:/Program Files/jboss-as-7.1.1.Final/bin/content/jbpm-gwt-console-server-5.4.0.Final-EE6.war/WEB-INF/lib/jaxb-impl-2.2.5.jar" does not point to a valid jar for a Class-Path reference.

12:57:14,157 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-2) Class Path entry activation.jar in "/C:/Program Files/jboss-as-7.1.1.Final/bin/content/jbpm-gwt-console-server-5.4.0.Final-EE6.war/WEB-INF/lib/jaxb-impl-2.2.5.jar"  does not point to a valid jar for a Class-Path reference.



3) Finally, I tried using the "Deploy" feature in the console.  The "Deployment" seemed to go OK but when I tried to Enable I got a "Processing" message that never closed.


My questions are:


1) How do I deploy just JBoss and jBPM (not the Full Install/Demo)?  I cannot locate any instructions for doing this; can you point me to documentation for this?

2) I am trying to locate the "source" of the six .War files installed by the Full Installer.  I' guessing that the following might be correct:

    Full Installer               

    jbpm-gwt-console.war                 jbpm-5.4.0.Final-gwt-console.zip            @ http://sourceforge.net/projects/jbpm/files/jBPM%205/jbpm-5.4.0.Final/

    jbpm-gwt-console-server.war        "

    jbpm-human-task-war.war        jbpm-5.4.0.Final-human-task-war.zip          @ http://sourceforge.net/projects/jbpm/files/jBPM%205/jbpm-5.4.0.Final/

    designer.war                           designer                                                  @ http://sourceforge.net/projects/jbpm/files/

    jbpm-form-builder.war              ???

    jbpm-gwt-console.war             ???

Is the above correct and where do the last two come from?  Further, how do these relate to the various files in jbpm-5.4.0.Final-bin.zip?

3) jbpm-5.4.0.Final-gwt-console.zip from http://sourceforge.net/projects/jbpm/files/jBPM%205/jbpm-5.4.0.Final/ contains the two files jbpm-gwt-console-server-5.4.0.Final-AS5.war and jbpm-gwt-console-server-5.4.0.Final-EE6.war.  What are these two?


Thank you.


Reply to this message by going to Community

Start a new discussion in jBPM at Community