False alarm, that was problem with my local settings.xml file. 

On Fri, May 22, 2015 at 11:18 AM, Denis Golovin <dgolovin@exadel.com> wrote:
... and build fails ;(

INFO] [ERROR] Cannot resolve project dependencies:
[INFO] [ERROR]   Software being installed: org.jboss.tools.aerogear.thym 1.3.0.qualifier
[INFO] [ERROR]   Missing requirement: org.eclipse.thym.core requires 'bundle org.eclipse.core.expressions [3.4.0,3.5.0)' but it could not be found
[INFO] [ERROR]   Cannot satisfy dependency: org.jboss.tools.aerogear.thym 1.3.0.qualifier depends on: bundle org.eclipse.thym.core 0.1.0

On Thu, May 21, 2015 at 4:10 PM, Nick Boldt <nboldt@redhat.com> wrote:
Target platform 4.50.0.Beta1-SNAPSHOT has been updated to Mars M7.

The decision was made today to have JBT 4.3.0.Beta1 / JBDS 9.0.0.Beta1
prereq JDK 8 as a Bundle-RequireExecutionEnvironment (BREE).

As such, Arquillian plugins that depend on Sapphire 9 have now been set
to a BREE of JavaSE-1.8 [1]. See JBIDE-19753.


Server Tools has also been updated to take advantage of the new
tm.terminal.* 4.0 plugins in place of the old tm.terminal 3.1 plugin.
See JBIDE-19776.


Next week, when it becomes available, we will start a new PR to update
the target platform to Mars RC2.

Reminder that code freeze for Beta1 is in TWO WEEKS on June 4, so the
finalized 4.50.0.Beta1 target platforms for JBT and JBDS need to be
released by June 3 at the latest.

Stay tuned!

On 05/14/2015 04:54 PM, Nick Boldt wrote:
> Some more updates to the M7 TP, while we decide what to do about
> Sapphire / Java 8.
> * remove fest (it was commented out already)
> * add org.eclipse.tm.terminal.control.feature.feature.group
> (rse.terminals requires it); remove old org.junit
> 3.8.2.v3_8_2_v20130308-0410
> * add org.eclipse.egit.ui.importer (needed for
> easymport)
> * jbosstools-server requests that the new tm.terminal views/connectors
> be installed along with it, so add org.eclipse.tm.terminal.*,
> connector.local.feature and org.eclipse.cdt.core.native.feature
> (JBIDE-17686, JBIDE-19776)
> * Switch to Mockito 1.9.5.v20131024-0922 (from Locus 1.2.0.Final site)
> If you haven't tried the latest M7 TP, please do so from this PR:
> https://github.com/jbosstools/jbosstools-target-platforms/pull/142/
> On 05/08/2015 04:02 AM, Max Rydahl Andersen wrote:
>> On 7 May 2015, at 21:25, Mickael Istria wrote:
>>> On 05/07/2015 08:32 PM, Alexey Kazakov wrote:
>>>> The new TP includes the updated Sapphire v.
>>>> Sapphire was updated in M7 and this version is not compatible with
>>>> Sapphire v. which was included in Mars TP before
>>>> (M1-M6)
>>>> Batch and Arquillian tools require Sapphire. It's not a big deal for
>>>> us to migrate Batch and Arquillian to new Sapphire API.
>>>> But the problem is that the new Sapphire (M7) has
>>>> *RequiredExecutionEnvironment: JavaSE-1.8*
>>> Too bad this wasn't spotted earlier. Is anyone following the Sapphire
>>> mailing-list or bugzilla component?
>> Sapphire announced it here:
>> https://www.eclipse.org/forums/index.php/t/890531/ back in January and
>> yes, really bad we did not catch that.
>> But we did monitor the release train but Sapphire did not put this
>> change until M7. Where it is IMO is too late as said over here
>> https://www.eclipse.org/forums/index.php/m/1694326
>> But Konstantin from Sapphire seem to not care about that ;/
>>>> If we can't require Java 8 for Batch and Arquillian then we have to
>>>> switch to Sapphire 8.2 from 9.0 in our TP.
>>>> Sapphire 8.2 supports Mars but Mars update site includes Sapphire
>>>> 9.0. only.
>>>> How are we going to deal with that?
>>> Well, Java 7 has reached end-of-life a few days ago, so I would
>>> support the idea of requiring Java 8 for those components. If they are
>>> part of JBDS default package, then it means that JBDS will also
>>> require Java 8.
>>> If we want to keep Java 7, we can simply include only Sapphire 8.2 in
>>> the target-platform and keep Sapphire 9.0 out. But I guess Sapphire
>>> 8.2 and 9.0 cannot be installed simultaneously; can they?
>> Konstantin claims they can - as long as you don't include two colliding
>> features that requires them.
>>> If not, then we need to make sure no other project that is important
>>> to us and that we want to work together with JBoss Tools relies on
>>> newer Sapphire.
>>> So is anyone aware of some other project that requires Sapphire and
>>> that we'd like to keep compatible with?
>> I've raised question internally to see if any objections against raising
>> to Java 8 since Java 7 is EOL'ed now *and* it seems its usage is
>> declining faster than Java 6 did.
>> /max
>> http://about.me/maxandersen
>> _______________________________________________
>> jbosstools-dev mailing list
>> jbosstools-dev@lists.jboss.org
>> https://lists.jboss.org/mailman/listinfo/jbosstools-dev

Nick Boldt :: JBoss by Red Hat
Productization Lead :: JBoss Tools & Dev Studio
jbosstools-dev mailing list