The attachments were too large for jdf-dev list. The screen shots are now located here:

-------- Original Message --------
Subject: Re: [jdf-dev] Need help with cheat sheet issues
Date: Fri, 26 Jul 2013 12:54:46 -0400
From: Sande Gilda <>
To: Nick Boldt <>
CC: Snjezana Peco <>, Rodney Russ <>, jdf-dev <>, external-exadel-list list <>

Snjezana made some comments in the pull, so I investigated further and discovered some interesting behavior.

So it appears the cheat sheet was created for a quickstart that is a subproject for all quickstarts and will not work when the project is moved to a different location.

My questions are:

  1. Is this the expected behavior or am I doing something wrong here? As I said, I'm new to cheat sheets. :-)
  2. Does JDBS do something differently in the case where there is a parent pom in the higher level directory, in this case, the root quickstart pom file?
  3. Does this mean cheat sheets will not work if a developer copies a quickstart project to a different location?
  4. In the near future, we plan to let developer download specific quickstarts independently. Will the cheat sheets work in this situation?


On 07/25/2013 12:12 PM, Sande Gilda wrote:
Problem solved. The path in the cheat sheet doesn't match the quckstart path name. I will make a comment in the pull.


On 07/25/2013 10:02 AM, Sande Gilda wrote:
Hi Nick,

I didn't even notice the error message in the status bar. I was looking for errors in the "Problems" window.

I have not renamed anything. I got that link from this open quickstart pull request I need to review:

It sounds like the cheat sheet may be referring to the artifactId rather than the folder name. I will investigate.

Thanks for the response.

On 07/25/2013 09:01 AM, Nick Boldt wrote:
The error message shown, "Cannot open the /jboss-as-kitchensink/..." suggests that either you created the project w/ a non-standard name, renamed it, or the cheatsheet assumes the wrong project name.

At any rate, there's a mismatch, but I'm not sure if it's user error (you renamed something) or cheatsheet error (invalid assumption on project path). Perhaps Snjezana can comment as to what happened.

Just out of curiosity, where are you finding links to Snjeza's github fork? Surely the *published* content for JBDS doesn't link to these intermediate / developer-owned resources, but to content in ?


On 07/25/2013 08:22 AM, Sande Gilda wrote:
I downloaded the final JDBS 7.0 GA yesterday and am making more
progress, but it's still not working as I would expect. I am testing the
kitchensink ".cheatsheet.xml" file located here:

'Click to perform' now works with no error.
When I first expand a file in the cheatsheet, there are no icons to
indicate you can do anything, only blank spaces (see 'index.xhtml').

I clicked in another panel and when I clicked back in the cheatsheet, I
see icons for Click to perform and Click to skip' for the
'default.xhtml' file. When I 'Click to perform', nothing happens. I
would expect it to open the file and go to the line number. Am I using
this incorrectly or expecting the wrong results? Screenshot is below.


On 07/22/2013 05:54 PM, Sande Gilda wrote:
Thanks Snjezana and Nick! I'm relieved to know that a JDBS upgrade
will help. Now I know who to contact for help. :-)

On 07/22/2013 04:52 PM, Snjezana Peco wrote:
command has been introduced in JBT 4.1/JBDS 7.0.
This command can't be used in JBDS 6.0.1.GA.


On 7/22/2013 9:20 PM, Rodney Russ wrote:
[adding jboss tools list - external-exadel]


    I am new to cheat sheets. I ran into issues testing quickstart
    pull 363, so I decided to take a step back and look at Max's
    basic cheatsheet-helloworld example. The source is here:

    I imported his quickstart into JDBS 6.0.1 GA,  went to Help -->
    Cheat Sheets. and opened the
    cheatsheet-helloworld/cheatsheet.xml file.

    The cheatsheet.xml source file contains this XML:
             title="Welcome to this project">
             It is important to force this to be run to make the
    variable resolved - a simple way to make that happen is to add
    an required command as seen below.

    In the cheat sheet in the right pane, I clicked on the "Click to
    perform" under the description above:

    I get this error:

    I also don't see any link under the "Open a file" section
    either. I believe there should be one based on this command:


    Does anyone have any idea what I'm doing wrong?


    jdf-dev mailing list

jdf-dev mailing list

jdf-dev mailing list