Could we just support both? It really depends on how you read it, but
onkeyup and keyup should be interchangeable. I guess implementations
could add this as an extension (to avoid such typos).

I'd originally argued for supporting the "on" version of the names, but the argument that carried the day was that the actual name of the event would be both more concise, and more accurate.

The idea of supporting both is interesting (be liberal in what you accept, after all), I don't think that it would cause any name conflicts.

However, at least in this case, the documentation is quite clear on this point:

The DOM event name is the actual DOM event name (for example: "click") as opposed to (for example: "onclick").

I suspect, however, it may be better to wait and see if this is a pain point for users...  It'd be easy to add this later without endangering existing code.

I supposed we could wait. However, the "on" prefix has been so ingrained in developers minds that it is almost one of those things that developers subconsciously add. For instance, in IE, the attachEvent() method has always required the "on" prefix in the event name, even though the actual DOM event name is the root word ("click" vs "onclick").

Anyone else on the EG have any thoughts about supporting both derivations today?


Dan Allen
Senior Software Engineer, Red Hat | Author of Seam in Action

NOTE: While I make a strong effort to keep up with my email on a daily
basis, personal or other work matters can sometimes keep me away
from my email. If you contact me, but don't hear back for more than a week,
it is very likely that I am excessively backlogged or the message was
caught in the spam filters.  Please don't hesitate to resend a message if
you feel that it did not reach my attention.