I tried it again after a bit and it worked. I was very anxious abd forgot about the big startup cost of web application servers. My bad. Sorry for all the noise.

Unfortunatelly tgis lasted just over night. The next morning openshift proxy failes to redirect to keycloak. I did not do anything to it, I swear.

I get bad request when I ,access it.

Pe 22 iul. 2015 10:10, "Stian Thorgersen" <stian@redhat.com> a scris:
Are you deploying to a private OpenShift? It seems to work just fine on OpenShift online.

The cartridge is just the WildFly cartridge with Keycloak added on top, do you have the same issue with that?

----- Original Message -----
> From: "Ioan Eugen Stan" <stan.ieugen@gmail.com>
> To: keycloak-user@lists.jboss.org
> Sent: Tuesday, 21 July, 2015 11:01:41 PM
> Subject: Re: [keycloak-user] Keycloak OpenShift Cartridge updated to  1.3.1.Final
> I found out that the keycloak is in fact running but it is not public by
> default. You can access it locally by forwarding the remote ports to
> your local ports: rhc port-forward keycloak and go to http://loalhost:8080/
> Any idea why keycloak is not available public by default? Is this an
> intended feature or bug? Any hints on how to make it public are
> aprecieated.
> Thanks,
> _______________________________________________
> keycloak-user mailing list
> keycloak-user@lists.jboss.org
> https://lists.jboss.org/mailman/listinfo/keycloak-user