On 06/01/2016 08:16 PM, Ron Sigal wrote:
About a month ago Katerina sent a note about the qe-internal RESTEasy testsuite at https://gitlab.mw.lab.eng.bos.redhat.com/jbossqe-eap/eap7-resteasy-ts, and I keep failing to look at it, until today's tjws thread. Katerina and everyone else who worked on it: I'm apologize for taking so long. It looks like a wonderful piece of work, and we absolutely have to take advantage of it.

1. I don't see an obvious one-one relationship between the upstream TS and the qe TS. Katerina, you said

The testsuite contains all tests from resteasy upstream (applicable to
current version of Resteasy in EAP, running with arquillian on EAP where
applicable). The rest are the unit tests.

I'm not quite sure how to interpret that. Could you say more about which parts of the upstream TS are in the qe TS and which parts aren't?
Hi Ron,

Katerina has PTO this week and next week, so she can't reply to you now.

There are no simple one-one relationship. We tried to put tests to suitable packages, that has often same name as in upstream TS.

2. If we copy the qe TS into a Resteasy module, can we just adapt those Resteasy tests missing from the qe TS and put the results in the new Resteasy module?
Yes, we can. QE has a list of test, which is not in QE TS ...

3. Technical question: I tried running the qe TS with -PexcludeFailing, but I get

[INFO] ------------------------------------------------------------------------
[INFO] Total time: 2.687 s
[INFO] Finished at: 2016-06-01T12:34:06-04:00
[INFO] Final Memory: 27M/277M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-surefire-plugin:2.19:test (default-test) on project resteasy-build-tools: groups/excludedGroups require TestNG or JUnit48+ on project test classpath -> [Help 1]

What am I doing wrong?

I have some other task this week, but I will look to this next week. Anyway, I have not seen this error yet ...