Hi Ganesh,
the issue DROOLS-419 was closed as non-Drools related, it was pointed as Maven related, and although this does not provide solution per-se, I have to agree with Drools team, the scenario I described was complex and the issue seems due to Maven.
Fortunately, as I have influence in changing the difficult integration scenario I'm facing, I solved this currently by running mvn install:install-file , so the correct kie module jar of the rules is present in the local .m2 repo. With this activity done separately, my Drools application find the kie module jar of the version I want already in the .m2 repo, and it works fine.

However, while this solved for the Drools application, I just actually shuffled the complexity around in the scenario, so I'm looking as a next step for a simpler way in achieving this automatically.

My suggestion to you would be same as in any complex integration scenario:
1. try to simplify scenario - I noticed Drools team updated documentation with also some cheat sheets for deployment, maybe something there or in the example can guide you
2. if you cannot simplify, try change approach - possibly you find a workaround as I did.

Finally, look out for the new release because possibly they solve your issues by side effects.

Hope this helps,

On Mon, May 26, 2014 at 11:01 AM, ganeshneelekani <ganeshneelekani@gmail.com> wrote:
Hi tari,

Did this issue get solved. i am facing the same issue with drools and maven,
Let me know your suggestions.

Ganesh Neelelkani

View this message in context: http://drools.46999.n3.nabble.com/rules-users-Cannot-find-KieModule-with-kieServices-newKieContainer-with-LATEST-or-RELEASE-instead-of-tp4027941p4029682.html
Sent from the Drools: User forum mailing list archive at Nabble.com.
rules-users mailing list