On Sun, Apr 4, 2010 at 2:24 AM, Lincoln Baxter, III <lincolnbaxter@gmail.com> wrote:
On Sun, Apr 4, 2010 at 1:00 AM, Jason Porter <lightguard.jp@gmail.com> wrote:
As a consumer I would love to see all qualifiers/annotations/interceptors/decorators/etc in the same package, it just makes things easier to find when you're looking for classes or javadoc.  This is also probably easier for people migrating from Seam2 to understand how to easily migrate.

Exactly! -- We should add decorators to the naming conventions established for interceptors:

Regardless of module, the following naming standards should be followed for Interceptors and Decorators:

org.jboss.seam.intercept.[name]Interceptor;
org.jboss.seam.decorate.[name]Decorator;

I do agree we can make a different case for interceptors and decorators as we do for qualifiers, events and other annotations. Interceptors and decorators need to be easy to type in XML, whereas qualifiers, events and other annotations just need to be IDE friendly (and can have a more variant classification structure).

While I've submitted my support for convention Lincoln suggests above, I'm also open to adding the module short name:

org.jboss.seam.[module].intercept.[name]Interceptor
org.jboss.seam.[module].intercept.[name]Interceptor

I do think we should agree on one of these two proposals for interceptors and decorators specifically.

-Dan

--
Dan Allen
Senior Software Engineer, Red Hat | Author of Seam in Action
Registered Linux User #231597

http://mojavelinux.com
http://mojavelinux.com/seaminaction
http://www.google.com/profiles/dan.j.allen