The logic in MappingRefactorModelHandler.refactorUserSql() is assuming a SPACE in the Old and New model names.

In the use-case below, the first model name is preceeded by a TAB character.

Also model names are not consistent : vPartsSupplier_Oracle vs vpartsSupplier_Oracle

TEIID/SQL is NOT case sensitive, so this method needs to take that into account TOO

Bottom line is, this method needs to be re-worked/fixed

SELECT
s.SUPPLIER_ID, s.SUPPLIER_NAME, s.SUPPLIER_STATUS, s.SUPPLIER_CITY, s.SUPPLIER_STATE, sp.PART_ID, sp.QUANTITY, sp.SHIPPER_ID
FROM
vPartsSupplier_Oracle.supplier AS s, vpartsSupplier_Oracle.supplier_Parts AS sp
WHERE
sp.SUPPLIER_ID = s.SUPPLIER_ID

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators.
For more information on JIRA, see: http://www.atlassian.com/software/jira