Hi Lutfi,

WildFly should run in SLES just fine.

To just play with it you can unzip it on your system, go to the bin dir in the unzipped installation and run the standalone.sh script. For more see https://docs.wildfly.org/18/Getting_Started_Guide.html

I believe SLES 12 also supports systemd. Beside the init.d folder you found, there's also a systemd folder.

I haven't tried this but poking around a bit I found https://gist.github.com/sukharevd/6087988 which has a lot of positive comments from folks who have used it to install WildFly as a service on various platforms.

Best regards,

On Wed, Nov 6, 2019 at 2:49 PM Nouman, Lutfi (SSC/SPC) <lutfi.nouman@canada.ca> wrote:

Hi all,


I have a server build that requires Wildfly application.


The OS that I will be using is SLES 12 SP 2.


Does Wildfly support SLES 12 SP 2? I have contacted SUSE Customer support and they unfamiliar with wildfly, they do not provide wildfly nor support.


They did mention that it should work with SLES without issues but they have not tried it.


When I downloaded the Wildfly 18 package to see what contents lie in there something came up. I believe you have scripts in the init.d folder for debian and red hat but not for SLES.


I also found an old forum of a user explaining in order to start and stop wildfly a script is needed.


Could you please give me some insight or more information?


Thank you for your time and effort on this matter.


Kind Regards,

Lutfi Nouman


Support Technician z/VM, Data Center Services Branch

Shared Services Canada / Government of Canada

lutfi.nouman@canada.ca / Tel: 343-543-5092


Technicien Informatique z/VM, Direction Générale des Services de Centres de Données

Services partagés Canada / Gouvernement du Canada

lutfi.nouman@canada.ca / Tél : 343-543-5092




wildfly-dev mailing list

Brian Stansberry
Manager, Senior Principal Software Engineer
Red Hat