Please see comments in the issue you submitted:
https://github.com/ocpsoft/rewrite/issues/179
This is intentional and I think it makes sense.
On Wed, Jul 23, 2014 at 7:20 AM, Ondrej Zizka <ozizka(a)redhat.com> wrote:
Hi,
we have 2 perform() methods: One for the rule, one for operation.
With the anonymous inner operations, this gets confusing:
ConfigurationBuilder.begin().addRule().
.perform(
new Operation(
.perform(
// Nested iteration
.perform(
new AnotherOperation(){
.perform( ... ){
}// end
perform()
}
)// end perform()
//
)// end perform()
)
)
;
Too many perform()'s.
I know this comes from OCP. I suggest to change it there.
Name can be anything, e.g. execute(), do(), wouldYouMind(), ... :)
WDYT?
Ondra
_______________________________________________
windup-dev mailing list
windup-dev(a)lists.jboss.org
https://lists.jboss.org/mailman/listinfo/windup-dev
--
Lincoln Baxter, III
http://ocpsoft.org
"Simpler is better."