[aerogear-dev] UPS Migrator error (1.1.0.Final)

Oleg Matskiv omatskiv at redhat.com
Thu Aug 13 03:45:31 EDT 2015

I have read that you have already reproduce, but anyway: version:
5.5.45 MySQL Community Server. I just created empty DB and ran
integration test with wildfly8UpsFromMavenRepository provider.
First it couldn't find "adm_variant" table (because of this i think:
So I tried to with runMigrator option and got that error about column


I did not create JIRA because this is for me first time working with
UPS and I thought that the mistake could simply be just on my side...

On Wed, Aug 12, 2015 at 12:37 PM, Oleg Matskiv <omatskiv at redhat.com> wrote:

> Hi,
> can somebody who worked on UPS migrator recently, check if it deals with
> recent database changes (e.g.
> https://github.com/aerogear/aerogear-unifiedpush-server/commit/bbe1c0e80a4a5295a3c7cefe66f5e8cc07da66be#diff-23e531d12489411024ea5c379be1d178R70
> ).
> I have run into error when running integration test with migrator run
> (liquibase.exception.DatabaseException:
> com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: Key column
> 'variantInformations_id' doesn't exist in table).
> Thanks for any help.
> --
> Oleg Matskiv
> Mobile QE Intern
> omatskiv at redhat.com

Oleg Matskiv
Mobile QE Intern
omatskiv at redhat.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.jboss.org/pipermail/aerogear-dev/attachments/20150813/cd088760/attachment.html 

More information about the aerogear-dev mailing list