[Aerogear-users] Android SDK doesn't work, any way to debug?

r00dY a.r.dabrowski at gmail.com
Wed Jan 11 05:15:15 EST 2017

Hi guys,

I've implemented aerogear push in Titanium app, iOS native app, so far so
good. Now need to integrate AG into Android and I'm struggling.

Steps I've done:
1. Set up project and app in Firebase console.
2. (tested push notifications by native Firebase SDK - they worked).
3. I add to gradle following stuff:

compile 'com.google.firebase:firebase-messaging:9.8.0'
compile 'org.jboss.aerogear:aerogear-android-push:4.1.0'

and use google-services plugin, version 3

4. I create Aerogear Android variant, set up Google API key (tried legacy
and new) and project ID from Firebase console (the ones that worked in a
native way).
5. I register for pushes using AG SDK and registration is OK (see new device
in admin panel).
7. I create message handler.
8. I send test push via "Send notification to this app" form. I set up text,
the rest of fields is left to "All".
9. I get callback that push notification is successfully sent.
10. Nothing happens on my device (tried Android 5, 6 and 7).

I was quite frustrated so I downloaded example project HelloPush
created for it new app in Firebase console and set up all configuration data
from my AeroGear panel. Same thing happens.

Any idea what may be the reason or do you have any methods for more detailed
debugging like:
1. Debugging of internals in Aerogear SDK, some verbose logging etc.
2. Debugging what's going on between Aerogear and Firebase while sending
push? Because I'm not sure if it's SDK fault or a fault of communication
between Aerogear and Firebase.

I can't wait for your answers, best!

View this message in context: http://aerogear-users.1116366.n5.nabble.com/Android-SDK-doesn-t-work-any-way-to-debug-tp1007.html
Sent from the aerogear-users mailing list archive at Nabble.com.

More information about the Aerogear-users mailing list