[arquillian-issues] [JBoss JIRA] (ARQ-1207) Support arquillian. prefix in configuration properties

Dan Allen (JIRA) jira-events at lists.jboss.org
Wed Nov 21 03:17:21 EST 2012


     [ https://issues.jboss.org/browse/ARQ-1207?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Dan Allen updated ARQ-1207:
---------------------------

    Description: 
Story:

*In order to* have more readable and intuitive property names
*As a* tester
*I want to* be able to use the arquillian. prefix to configure properties, or no prefix if the properties are specified in an arquillian.properties file

Scenario:

*Given* that I define a system property or a property in arquillian.properties which uses the prefix arquillian. instead of arq.
*When* Arquillian loads the configuration
*Then* the property should be recognized

*Given* that I define a property in arquillian.properties which does not use an arquillian-specific prefix
*When* Arquillian loads the configuration
*Then* the property should be recognized

Rationale:

The arq. prefix may be convenient for some, but to newcomers it's cryptic. We should support both the shorthand (arq.) and the full prefix (arquillian.) when loading properties.

Since the property matches are done using regular expressions, it should not be hard to add support for both prefixes.

I also recommend allowing extension to be abbreviated "ext". Thus, to configure webdriver, I could use any of these property declarations:

{code}
arquillian.extension.webdriver.browserCapabilities=firefox
arquillian.ext.webdriver.remoteReusable=true
arq.ext.webdriver.remoteAddress=http://127.0.0.1:4444/wd/hub/
{code}

Since we are reading properties from an arquillian.properties file, we could prepend the arquillian. prefix automatically, thus making it optional.

{code}
extension.webdriver.browserCapabilities=firefox
{code}

The prefix is really only needed for system properties, which need the qualified namespace.

  was:
Story:

*In order to* have more readable and intuitive property names
*As a* tester
*I want to* be able to use the arquillian. prefix to configure properties in the arquillian.properties file

Scenario:

*Given* that I define a property in arquillian.properties which uses the prefix arquillian. instead of arq.
*When* Arquillian loads the configuration
*Then* the property should be recognized

Rationale:

The arq. prefix may be convenient for some, but to newcomers it's cryptic. We should support both the shorthand (arq.) and the full prefix (arquillian.) when loading properties.

Since the property matches are done using regular expressions, it should not be hard to add support for both prefixes.

I also recommend allowing extension to be abbreviated "ext". Thus, to configure webdriver, I could use any of these property declarations:

{code}
arquillian.extension.webdriver.browserCapabilities=firefox
arquillian.ext.webdriver.remoteReusable=true
arq.ext.webdriver.remoteAddress=http://127.0.0.1:4444/wd/hub/
{code}


    
> Support arquillian. prefix in configuration properties
> ------------------------------------------------------
>
>                 Key: ARQ-1207
>                 URL: https://issues.jboss.org/browse/ARQ-1207
>             Project: Arquillian
>          Issue Type: Feature Request
>      Security Level: Public(Everyone can see) 
>          Components: Configuration
>    Affects Versions: 1.0.3.Final
>            Reporter: Dan Allen
>            Priority: Minor
>
> Story:
> *In order to* have more readable and intuitive property names
> *As a* tester
> *I want to* be able to use the arquillian. prefix to configure properties, or no prefix if the properties are specified in an arquillian.properties file
> Scenario:
> *Given* that I define a system property or a property in arquillian.properties which uses the prefix arquillian. instead of arq.
> *When* Arquillian loads the configuration
> *Then* the property should be recognized
> *Given* that I define a property in arquillian.properties which does not use an arquillian-specific prefix
> *When* Arquillian loads the configuration
> *Then* the property should be recognized
> Rationale:
> The arq. prefix may be convenient for some, but to newcomers it's cryptic. We should support both the shorthand (arq.) and the full prefix (arquillian.) when loading properties.
> Since the property matches are done using regular expressions, it should not be hard to add support for both prefixes.
> I also recommend allowing extension to be abbreviated "ext". Thus, to configure webdriver, I could use any of these property declarations:
> {code}
> arquillian.extension.webdriver.browserCapabilities=firefox
> arquillian.ext.webdriver.remoteReusable=true
> arq.ext.webdriver.remoteAddress=http://127.0.0.1:4444/wd/hub/
> {code}
> Since we are reading properties from an arquillian.properties file, we could prepend the arquillian. prefix automatically, thus making it optional.
> {code}
> extension.webdriver.browserCapabilities=firefox
> {code}
> The prefix is really only needed for system properties, which need the qualified namespace.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira


More information about the arquillian-issues mailing list