[cdi-dev] [JBoss JIRA] Updated: (CDI-17) Change name of the @Observes Reception attribute to "notified"

Pete Muir (JIRA) jira-events at lists.jboss.org
Wed Jan 26 19:27:51 EST 2011

     [ https://issues.jboss.org/browse/CDI-17?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Pete Muir updated CDI-17:

    Fix Version/s: TBD
                       (was: 1.1)

> Change name of the @Observes Reception attribute to "notified"
> --------------------------------------------------------------
>                 Key: CDI-17
>                 URL: https://issues.jboss.org/browse/CDI-17
>             Project: CDI Specification Issues
>          Issue Type: Feature Request
>          Components: Javadoc and API
>    Affects Versions: 1.0
>            Reporter: Dan Allen
>            Priority: Minor
>             Fix For: TBD
> As of the CDI 1.0 specification, the name of the Reception attribute on @Observes is "receive". The patch release of the API (SP1) changes the name to "notifyObserver", so a change is already being considered. Therefore, I'd like to suggest a better name that would read more fluently. That name is "notified".
> Let us compare the three cases:
> 1. @Observes(receive = IF_EXISTS)
> 2. @Observes(notifyObserver = IF_EXISTS)
> 3. @Observes(notified = IF_EXISTS)
> Of the three, notifyObserver breaks the flow of the sentence the most. On the other hand, notified reads nicely, including with the TransactionPhase attribute included:
> @Observes(notified = IF_EXISTS, during = TransactionPhase.AFTER_SUCCESS)

This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira


More information about the cdi-dev mailing list