[dna-issues] [JBoss JIRA] Created: (DNA-208) Path API's getAncestor() method should be renamed to getParent()

Johnny Verhaeg (JIRA) jira-events at lists.jboss.org
Wed Aug 20 11:17:35 EDT 2008


Path API's getAncestor() method should be renamed to getParent()
----------------------------------------------------------------

                 Key: DNA-208
                 URL: https://jira.jboss.org/jira/browse/DNA-208
             Project: DNA
          Issue Type: Feature Request
          Components: SPI
    Affects Versions: 0.1
            Reporter: Johnny Verhaeg
            Assignee: Johnny Verhaeg
             Fix For: 0.2


"getAncestor" always returns just the parent and not any ancestor, as the name implies.  The getAncestor(int) method provides the ability to get to any ancestor.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: https://jira.jboss.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        



More information about the dna-issues mailing list