[dna-issues] [JBoss JIRA] Commented: (DNA-76) Create a SequencerInput class to encapsulate both the InputStream and path of the node being sequenced

Johnny Verhaeg (JIRA) jira-events at lists.jboss.org
Wed May 21 16:30:59 EDT 2008


    [ http://jira.jboss.com/jira/browse/DNA-76?page=comments#action_12413611 ] 
            
Johnny Verhaeg commented on DNA-76:
-----------------------------------

That's fine, but then we need to come up with a different name for the class, like SequencerInfo

> Create a SequencerInput class to encapsulate both the InputStream and path of the node being sequenced
> ------------------------------------------------------------------------------------------------------
>
>                 Key: DNA-76
>                 URL: http://jira.jboss.com/jira/browse/DNA-76
>             Project: DNA
>          Issue Type: Feature Request
>          Components: Sequencers
>            Reporter: Johnny Verhaeg
>             Fix For: 0.2
>
>
> Custom sequencers will need the path of the input node to, for instance, produce detailed log messages.  The StreamSequencer.sequence method would be updated to take this class as a parameter in place of an InputStream.  May want to consider changing StreamSequencer to just Sequencer, possibly allowing for other ways besides InputStream to read from the node.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.jboss.com/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        



More information about the dna-issues mailing list