[dna-issues] [JBoss JIRA] Updated: (DNA-205) Rename/refactor classes
Randall Hauch (JIRA)
jira-events at lists.jboss.org
Wed Sep 10 13:48:38 EDT 2008
[ https://jira.jboss.org/jira/browse/DNA-205?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Randall Hauch updated DNA-205:
------------------------------
Summary: Rename/refactor classes (was: Rename "org.jboss.dna.common.util.ArgCheck" to "org.jboss.dna.common.util.CheckArg")
Description:
The following are some changes that we need to make that will have a large impact on the codebase, and so we want to do these toward the end of the release when all other changes have been made.
1) Rename "org.jboss.dna.common.util.ArgCheck" to "org.jboss.dna.common.util.CheckArg", since the latter is more readable.
2) Rename the "dna-spi" project to "dna-graph", since it will house not only the SPI but a new API (DNA-215). The package structure will be changed to be:
- org.jboss.dna.graph => The location of the new API (plus package-level implementations) and ExecutionContext and other major interfaces
- org.jboss.dna.graph.properties => The new location for what is now "o.j.d.spi.graph" (the property and value interfaces), and where the implementations will be moved and made package-level.
- org.jboss.dna.graph.cache => The interfaces for the caching policy (what is now "o.j.d.spi.cache")
- org.jboss.dna.graph.commands => The new location for what is now "o.j.d.spi.graph.commands" and "...commands.impl"
- org.jboss.dna.graph.connectors => The SPI interfaces for the connectors (what is now "o.j.d.spi.connectors")
- org.jboss.dna.graph.sequencers => The SPI interface(s) for the sequencer
- org.jboss.dna.graph.mimetypes => The SPI interface(s) for the MIME type detectors
- org.jboss.dna.graph.util => The location for graph utilities (e.g., graph importers, maybe the XML sequencer)
was:Minor nit, but "CheckArg.isNotNull(...)" is more readable than "ArgCheck.isNotNull(...)". We should do this first thing after the 0.2 release, since it will impact a huge percentage of the code.
Complexity: Low
Priority: Major (was: Minor)
> Rename/refactor classes
> -----------------------
>
> Key: DNA-205
> URL: https://jira.jboss.org/jira/browse/DNA-205
> Project: DNA
> Issue Type: Task
> Components: Common
> Affects Versions: 0.2
> Reporter: Randall Hauch
> Assignee: Randall Hauch
> Fix For: 0.2
>
>
> The following are some changes that we need to make that will have a large impact on the codebase, and so we want to do these toward the end of the release when all other changes have been made.
> 1) Rename "org.jboss.dna.common.util.ArgCheck" to "org.jboss.dna.common.util.CheckArg", since the latter is more readable.
> 2) Rename the "dna-spi" project to "dna-graph", since it will house not only the SPI but a new API (DNA-215). The package structure will be changed to be:
> - org.jboss.dna.graph => The location of the new API (plus package-level implementations) and ExecutionContext and other major interfaces
> - org.jboss.dna.graph.properties => The new location for what is now "o.j.d.spi.graph" (the property and value interfaces), and where the implementations will be moved and made package-level.
> - org.jboss.dna.graph.cache => The interfaces for the caching policy (what is now "o.j.d.spi.cache")
> - org.jboss.dna.graph.commands => The new location for what is now "o.j.d.spi.graph.commands" and "...commands.impl"
> - org.jboss.dna.graph.connectors => The SPI interfaces for the connectors (what is now "o.j.d.spi.connectors")
> - org.jboss.dna.graph.sequencers => The SPI interface(s) for the sequencer
> - org.jboss.dna.graph.mimetypes => The SPI interface(s) for the MIME type detectors
> - org.jboss.dna.graph.util => The location for graph utilities (e.g., graph importers, maybe the XML sequencer)
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: https://jira.jboss.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira
More information about the dna-issues
mailing list