[dna-issues] [JBoss JIRA] Resolved: (DNA-485) Standardize Default Workspace Name Property Across Sources

Brian Carothers (JIRA) jira-events at lists.jboss.org
Sun Jul 12 18:01:29 EDT 2009


     [ https://jira.jboss.org/jira/browse/DNA-485?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Brian Carothers resolved DNA-485.
---------------------------------

    Fix Version/s: 0.6
       Resolution: Done
         Assignee: Brian Carothers


Resolved defect by applying patch

> Standardize Default Workspace Name Property Across Sources
> ----------------------------------------------------------
>
>                 Key: DNA-485
>                 URL: https://jira.jboss.org/jira/browse/DNA-485
>             Project: DNA
>          Issue Type: Feature Request
>          Components: API, Connectors
>    Affects Versions: 0.5
>            Reporter: Brian Carothers
>            Assignee: Brian Carothers
>            Priority: Minor
>             Fix For: 0.6
>
>         Attachments: DNA-485.patch
>
>
> Most (if not all) repositories will likely have the concept of a default workspace that has a configurable name.  The in-memory, JBoss Cache, and Infinispan repositories already have this feature.  However, they use different names for the property on the repository source object (in-memory -> defaultWorkspaceName, JBC -> nameOfDefaultWorkspace, Infinispan -> nameOfDefaultWorkspace).
> Strictly speaking, this is a syntactically acceptable approach, but from a usability standpoint, it makes sense to establish naming conventions for common property names.  Since the in-memory repository is very widely used in the codebase already, it probably makes the most sense to standardize on "defaultWorkspaceName" as the property containing the name of the default workspace.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: https://jira.jboss.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        



More information about the dna-issues mailing list