[forge-dev] [JBoss JIRA] Commented: (SEAMFORGE-166) Getting ***ERROR*** [set] null on a couple of commands

Lincoln Baxter III (JIRA) jira-events at lists.jboss.org
Thu May 12 14:14:31 EDT 2011

    [ https://issues.jboss.org/browse/SEAMFORGE-166?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12601745#comment-12601745 ] 

Lincoln Baxter III commented on SEAMFORGE-166:

Ok, I know why this is happening, and I guess it means we need to do a little work on the way we use the group-id as the default package (an additional verification step is required.)

Your selected groupId/topLevelPackage is: "com.package"... unfortunately, "package" is a reserved java keyword, which is why the JDT is barfing on it. We need to prevent this from being used as the package, prompting for a new package if a bad word is detected in the initial value.

> Getting ***ERROR*** [set] null on a couple of commands
> ------------------------------------------------------
>                 Key: SEAMFORGE-166
>                 URL: https://issues.jboss.org/browse/SEAMFORGE-166
>             Project: Seam Forge
>          Issue Type: Bug
>          Components: Builtin Plugins
>    Affects Versions: 1.0.0.Alpha4
>            Reporter: Rodney Russ
> In running through "First Steps with Scaffolding" in the docs, I got an "***ERROR*** [set] null" as a result of step 5 (incidentally, the new-entity has changed to just entity).  I wanted to figure out what was going on and tried to execute "set VERBOSE" and actually got the same error.
> I built the lastest code from master in trying to do this.

This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira


More information about the forge-dev mailing list