[forge-dev] some problems on scaffold template

JFlower fiorenzino at gmail.com
Thu Aug 16 20:00:55 EDT 2012


Hi,

i created https://issues.jboss.org/browse/FORGE-655.
I created my branch [https://github.com/fiorenzino/core/tree/FORGE-655] and
committed my simple changes,
but i added also my starting code for
https://issues.jboss.org/browse/FORGE-610

i think i should revert my changes for FORGE-610, branch from origin, and
finally add my changes and commit...

but i don't know how... [perhaps using git rebase..]

...ops...

fiorenzo



2012/8/17 JFlower <fiorenzino at gmail.com>

> Hi George,
>
> i will try..
> i'm a beginner git user..
>
> Fiorenzo
>
>
> 2012/8/17 George Gastaldi <ggastald at redhat.com>
>
>> Awesome ! Can you create a pull request with that ?
>>
>> Thanks
>>
>> Em 16/08/2012, às 19:31, JFlower <fiorenzino at gmail.com> escreveu:
>>
>> Another stupid thing,
>>
>>  in the resource folder the image jboss-community.png doesn't exist (it's
>> used in the error page:
>>
>> https://github.com/forge/core/blob/master/scaffold-faces/src/main/resources/scaffold/faces/error.xhtml
>> )
>>
>> fiorenzo
>>
>> 2012/8/17 JFlower <fiorenzino at gmail.com>
>>
>>> Hi,
>>>
>>> i would suggest 2 thinks to improve the scaffold from entities.
>>>
>>> With forge 1.0.6, the project generated usign scaffold from-entity have
>>> wrong link in the nav bar for the principal link (with brand class).
>>> In my case, i created a "flower" app and the html div is:
>>>
>>> <div class="navbar navbar-fixed-top">
>>> <div class="navbar-inner">
>>>  <div class="container">
>>> <a href="/index.xhtml" class="brand">Flower</a>
>>>  <div class="nav-collapse collapse">
>>> <ul class="nav">
>>>  <li><a href="
>>> http://forge.jboss.org/docs/important_plugins/ui-scaffolding.html">How
>>> to Customize</a></li>
>>>  </ul>
>>> </div>
>>> </div>
>>>  </div>
>>> </div>
>>>
>>> In pageTemplate (
>>> https://github.com/forge/core/blob/master/scaffold-faces/src/main/resources/scaffold/faces/pageTemplate.xhtml)
>>> the link should be:
>>>
>>> <h:link  id="brandLink" outcome="@{targetDir}/index.xhtml"
>>> styleClass="brand"> <h:outputText value="@{appName}" /></h:link>
>>> in place of:
>>> <a href="@{targetDir}/index.xhtml" class="brand">@{appName}</a>
>>>
>>> [to avoid a wrong redirect to http://localhost:8080/index.xhtml]
>>>
>>> And to eliminate the annoying log jboss server log:
>>> 23:59:54,914 AVVERTENZA
>>> [javax.enterprise.resource.webcontainer.jsf.context]
>>> (http--127.0.0.1-8080-1) JSF1091: No mime type could be found for file
>>> favicon.ico.  To resolve this, add a mime-type mapping to the applications
>>> web.xml
>>>
>>> you should add on web.xml:
>>>
>>>    <mime-mapping>
>>>          <extension>ico</extension>
>>>          <mime-type>image/x-icon</mime-type>
>>>      </mime-mapping>
>>>
>>>
>>> Best regards
>>>
>>> fiorenzo
>>>
>>>
>> _______________________________________________
>> forge-dev mailing list
>> forge-dev at lists.jboss.org
>> https://lists.jboss.org/mailman/listinfo/forge-dev
>>
>>
>> _______________________________________________
>> forge-dev mailing list
>> forge-dev at lists.jboss.org
>> https://lists.jboss.org/mailman/listinfo/forge-dev
>>
>>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.jboss.org/pipermail/forge-dev/attachments/20120817/5b1878b9/attachment.html 


More information about the forge-dev mailing list