[forge-dev] Aesh & Eclipse

Ståle W. Pedersen spederse at redhat.com
Wed Nov 21 10:26:49 EST 2012

hi, i just tested on eclipse and we just need to define some input
streams and terminals to make it to "work". by "work" i mean getting the
input, keybindings/movment etc requires that the console in eclipse get
fed that input.
i briefly talked with koen and he mentioned that they had that covered
in jboss tools.

i have some trouble with maven atm. many of my projects (including
forge) fail with this exception:
Caused by: java.lang.IllegalArgumentException: Malformed \uxxxx encoding
i just finished a run as root and that worked so its something fishy in
my env. ill do a push request when i have things working.


On Wed 2012-11-21 15:19, Ståle W. Pedersen wrote:
> hi, sorry for the late reply, been away today. ill download eclipse and
> test it a bit. ill contact you later today.
> ståle
> On Tue 2012-11-20 13:36, Lincoln Baxter, III wrote:
> > The behavior seems to be that the shell prompt is printed to the terminal,
> > but input is never returned by the "prompt(...) while loop." Though I do
> > see the prompt repeating when I press <ENTER> while your test case is
> > running. Not really sure what is happening.
> > 
> > 
> > On Tue, Nov 20, 2012 at 1:35 PM, Lincoln Baxter, III <
> > lincolnbaxter at gmail.com> wrote:
> > 
> > > Hey Stale,
> > >
> > > I tried to get Aesh to accept user input from the test case, but it does
> > > not seem like it is working in Eclipse. You mentioned you were going to be
> > > working on that.
> > >
> > > What needs to be done, and when do you think you might be able to work on
> > > it? I'd like to start playing with the shell, and I think we're ready to
> > > start porting some more things over from Forge 1.
> > >
> > > Thanks a lot!

More information about the forge-dev mailing list