[forge-users] Forge 1.0.0.SNAPSHOT incompatible with forge plugin repository

Thomas Frühbeck fruehbeck at aon.at
Sun Sep 25 06:22:12 EDT 2011


I tried to setup and use Forge following the documentation, but I found 
some incompatibilities of forge and the plugins, especially with 
arquillian and prettyfaces.

Caused by: java.lang.ClassNotFoundException: 
     from [Module "com.ocpsoft.forge.prettyfaces-plugin:1.0.0.Alpha4"
     from local module loader @5f159092 (roots: 

I found that Forge is already built with shrinkwrap.version = 1.0.0-beta-5
but prettyfaces-forge-plugin refers to forge.version = 1.0.0.Alpha-4 
which refers to an older version of shrinkwrap.

I then tried to modify forge-test-harness to make it build with 
shrinkwrap 1.0.0.beta-5 and arquillian 1.0.0-SNAPSHOT which did not look 
too difficult. But after some refactoring it built but it did not work.

I then tried to revert to forge.version 1.0.0.Alpha3 but this did not 
produce a working app on jboss-as-7.0.1.

Somehow I seem to have reached some dead end :-/

Could you please give a short wrap-up what the current list of 
dependencies and runtime environments are to produce a working application.

Thanks and regards,

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.jboss.org/pipermail/forge-users/attachments/20110925/743b1dea/attachment.html 

More information about the forge-users mailing list