[forge-users] Forge 1.0.0.SNAPSHOT incompatible with forge plugin repository

Thomas Frühbeck fruehbeck at aon.at
Thu Sep 29 18:15:51 EDT 2011

Hi Lincoln,
yes, the zipped version started without fail, but
     - I used the repository URL 
         I had to create the "DEFFAULT_PLUGIN_REPO" too to make forge 
recognize the entry
     - the plugins could be installed, but on "forge list-plugins" none 
where shown, so I am a bit uneasy if it really worked

I created a new webapp and tried to deploy it. I got a 
DefinitionException and the deployment failed:

Caused by: org.jboss.weld.exceptions.DefinitionException: WELD-001103 
Cannot declare qualifiers on stereotype interface 

Could you pleas help with this error?

Thanks and gratulations to this great project,

Am 29.09.2011 06:37, schrieb Lincoln Baxter, III:
> Hi Thomas,
> Sorry for the late reply.
> Please try the latest Forge snapshot with the current version of the 
> PrettyFaces and Arquillian plugins from the repository:
> https://repository.jboss.org/nexus/index.html#nexus-search;gav~org.jboss.forge~forge-distribution~~~~kw,versionexpand 
> <https://repository.jboss.org/nexus/index.html#nexus-search;gav%7Eorg.jboss.forge%7Eforge-distribution%7E%7E%7E%7Ekw,versionexpand>
> forge install-plugin prettyfaces
> forge install-plugin arquillian
> Also note that you no longer need to restart forge after installing 
> plugins.
> Let me know if you have any trouble!
> Thanks,
> ~Lincoln
> On Sun, Sep 25, 2011 at 6:22 AM, Thomas Frühbeck <fruehbeck at aon.at 
> <mailto:fruehbeck at aon.at>> wrote:
>     Hi,
>     I tried to setup and use Forge following the documentation, but I
>     found some incompatibilities of forge and the plugins, especially
>     with arquillian and prettyfaces.
>     Caused by: java.lang.ClassNotFoundException:
>     org.jboss.shrinkwrap.descriptor.spi.Node
>         from [Module "com.ocpsoft.forge.prettyfaces-plugin:1.0.0.Alpha4"
>         from local module loader @5f159092 (roots:
>     /home/thomas/java/forge-1.0.0-SNAPSHOT/modules,/home/thomas/.forge/plugins)]
>     I found that Forge is already built with shrinkwrap.version =
>     1.0.0-beta-5
>     but prettyfaces-forge-plugin refers to forge.version =
>     1.0.0.Alpha-4 which refers to an older version of shrinkwrap.
>     I then tried to modify forge-test-harness to make it build with
>     shrinkwrap 1.0.0.beta-5 and arquillian 1.0.0-SNAPSHOT which did
>     not look too difficult. But after some refactoring it built but it
>     did not work.
>     I then tried to revert to forge.version 1.0.0.Alpha3 but this did
>     not produce a working app on jboss-as-7.0.1.
>     Somehow I seem to have reached some dead end :-/
>     Could you please give a short wrap-up what the current list of
>     dependencies and runtime environments are to produce a working
>     application.
>     Thanks and regards,
>     Thomas
>     _______________________________________________
>     forge-users mailing list
>     forge-users at lists.jboss.org <mailto:forge-users at lists.jboss.org>
>     https://lists.jboss.org/mailman/listinfo/forge-users
> -- 
> Lincoln Baxter, III
> http://ocpsoft.com
> http://scrumshark.com
> "Keep it Simple"
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.jboss.org/pipermail/forge-users/attachments/20110930/d3730443/attachment.html 

More information about the forge-users mailing list