[forge-users] Forge 2.x gets stuck at the start

Lincoln Baxter, III lincolnbaxter at gmail.com
Wed Jul 2 09:58:01 EDT 2014

Hi Ondra, Sorry you're having trouble. Could you try downloading a recent
Forge distribution and deleting your ~/.forge directory. Also make sure
that your $FORGE_HOME is not set to something old (you don't need it
anymore at all actually.)

Let me know how that goes. Sorry for the delay in answering!


On Mon, Jun 30, 2014 at 7:21 AM, <forge-users at lists.jboss.org> wrote:

> Hi,
> I would like ask whether somebody does not have troubles with starting
> Forge? Or experience with the following behaviour.
> I'm not able to start it on my local machine from version 2.1.x or
> something. All the following versions do the same problem to me.
> When I run the forge command the Forge get stuck. I can see ASCII logo of
> the program but then nothing and I wait for the command shell indefinitely.
> The strange thing is that when I tried to start Forge under JDK 1.8 from
> distribution without addons then it started with warning (this is maybe
> connected with using 64b instead of 32b)
> {quote:class=jive_text_macro jive_macro_quote}
> Java HotSpot(TM) 64-Bit Server VM warning: You have loaded library
> /tmp/1404127116808-0/native/unix_32_xadisk.native which might have disabled
> stack guard. The VM will try to fix the stack guard now.
> It's highly recommended that you fix the library with 'execstack -c
> <libfile>', or link it with '-z noexecstack'.
> {quote}
> But when I switched to distribution with addons then all the Forge get
> stuck again. If I run JDK 1.7 then I'm not able to start Forge neither with
> nor without addons.
> I'm running 64b java 1.7 on Fedora 20. I'm putting here the stack trace of
> the Forge at the start in case that it would help identify my problem.
> Thanks
> Ondra
> Posted by forums
> Original post: https://community.jboss.org/message/879862#879862
> _______________________________________________
> forge-users mailing list
> forge-users at lists.jboss.org
> https://lists.jboss.org/mailman/listinfo/forge-users

Lincoln Baxter, III
"Simpler is better."
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.jboss.org/pipermail/forge-users/attachments/20140702/bca68d9d/attachment.html 

More information about the forge-users mailing list