[forge-users] CDI error when attempting to create scaffold.

George Labuschagne george.labuschagne at gmail.com
Sat Aug 12 12:31:41 EDT 2017

Hi all

I recently discovered this amazing tool Forge. Thanks to everybody
involved in making it.

I downloaded the latest version 3.7.2 and added the forge executable to
my path.

All works very well apart from when I:
1. Want to setup JSF to use version 2.2 (pressing tab after entering
faces-setup yields no options at all. I would have hoped that it had an
option like --version which could be set to 2.2 or 2.0 depending on the
current code base.
2. When I run scaffold-setup --provider Faces I get the following

	[edsnext]$ scaffold-setup --provider Faces            
	***ERROR*** Could not install CDI.
	***SUCCESS*** Scaffold was setup successfully.

Running cdi-setup gives exactly the same error.

What do I need to do to remedy this please?

George Labuschagne
Cell: +27 83 451 9443
Email: george.labuschagne at gmail.com
Twitter: @georgelappies

This email has been checked for viruses by Avast antivirus software.

More information about the forge-users mailing list