<div dir="ltr">Hi there,<div><br>A few things that will hopefully clear up these issues :)</div><div><br></div><div>The Errai plugin is for Forge 2. It won&#39;t work in Forge 1.</div><div><br></div><div>Based on the Forge 2 output you pasted, it looks like you were trying to run `forge --install xxxxxx` from within Forge shell itself. This command must be run from your system terminal, outside of Forge 2. To install addons within Forge, you can use the: `addon-install` command.</div>
<div><br></div><div>Also, a hint: Press &lt;TAB&gt; to see a list of available commands within Forge 2.</div><div><br></div><div>Cheers!</div></div><div class="gmail_extra"><br><br><div class="gmail_quote">On Mon, Mar 3, 2014 at 6:42 AM,  <span dir="ltr">&lt;<a href="mailto:forge-users@lists.jboss.org" target="_blank">forge-users@lists.jboss.org</a>&gt;</span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">Hi<br>
<br>
I&#39;m a first time user of forge, so please forgive me if these seem like stupid questions.<br>
<br>
I&#39;ve wanting to use forge as it seems like it will speed update development, especially of erria applications.<br>
<br>
I installed Forge, as documented on errai/forge-errai  GitHub (<a href="https://github.com/errai/forge-errai" target="_blank">https://github.com/errai/forge-errai</a>) and <a href="https://github.com/forge/core#jboss-forge-20" target="_blank">https://github.com/forge/core#jboss-forge-20</a><br>

<br>
Firstly, I tried installing it into JBDS. According to the documentation I should be able to hit ctrl-5 and the Forge UI should show. This did not happen.<br>
<br>
I tried the eclipse console, and tried to add the errai plugin.<br>
<br>
Wrote /home/anton/.forge/httpsrawgithubcomforgepluginrepositorymasterrepositoryyaml.yaml<br>
[magick.watcher] dev $ forge install-plugin errai<br>
***INFO*** Preparing to install plugin: errai<br>
***INFO*** Checking out plugin source files to [/tmp/forgetemp6427039614160685695] via &#39;git&#39;<br>
***INFO*** Switching to branch/tag [refs/heads/master]<br>
***INFO*** Cleaning up temp workspace [/tmp/forgetemp6427039614160685695]<br>
Deleted /tmp/forgetemp6427039614160685695<br>
***ERROR*** Exception encountered: The project does not contain a valid Forge Plugin project. Installation aborted (type &quot;set VERBOSE true&quot; to enable stack traces)<br>
<br>
<br>
<br>
<br>
 _____<br>
 | ___|__ _ __ __ _ ___<br>
 | |_ / _ \| `__/ _` |/ _ \ \\<br>
 | _| (_) | | | (_| | __/ //<br>
 |_| \___/|_| \__, |\___|<br>
 |___/<br>
<br>
<br>
JBoss Forge, version [ 2.1.1.Final ] - JBoss, by Red Hat, Inc. [ <a href="http://forge.jboss.org" target="_blank">http://forge.jboss.org</a> ]<br>
<br>
<br>
[bin]$ forge<br>
***ERROR*** No such command: forge<br>
[bin]$ forge Project: New<br>
***ERROR*** No such command: forge<br>
[bin]$ forge --install core<br>
***ERROR*** No such command: forge<br>
[bin]$ forge --install shell<br>
***ERROR*** No such command: forge<br>
[bin]$<br>
<br>
I am obviously doing something very wrong. Can someone please help me?<br>
I would preferably use the UI in eclipse, but am fine with using the command line. Unfortunately neither is working.<br>
<br>
Posted by forums<br>
Original post: <a href="https://community.jboss.org/message/860448#860448" target="_blank">https://community.jboss.org/message/860448#860448</a><br>
<br>
_______________________________________________<br>
forge-users mailing list<br>
<a href="mailto:forge-users@lists.jboss.org">forge-users@lists.jboss.org</a><br>
<a href="https://lists.jboss.org/mailman/listinfo/forge-users" target="_blank">https://lists.jboss.org/mailman/listinfo/forge-users</a></blockquote></div><br><br clear="all"><div><br></div>-- <br>Lincoln Baxter, III<br><a href="http://ocpsoft.org" target="_blank">http://ocpsoft.org</a><br>
&quot;Simpler is better.&quot;
</div>