[hibernate-dev] Unable to checkout core/trunk/core

Sanne Grinovero sanne.grinovero at gmail.com
Fri Oct 16 07:50:56 EDT 2009

Hi Paul,
I've tried again, deleting my settings and:

svn checkout http://anonsvn.jboss.org/repos/hibernate/core/branches/Branch_3_3/core
-r HEAD --depth=infinity --force core
--> ...Checked out revision 17773.

just works.

could you try from commandline?

output from "svn --version" :
svn, version 1.6.5 (r38866)
   compiled Aug 23 2009, 05:25:21


2009/10/16 Paul Benedict <pbenedict at apache.org>:
> Just an update: I upgraded my SVN client and Eclipse plugin both to
> the 1.6 series with no better luck. That 403 error on that mystery
> path is beyond me. Since it errors on the REPORT command, I wonder if
> your guys Apache is setup to handle that command? Notice it's not a
> 404 so a file is found, but it is forbidden.
> I did try both JavaHL and SVNKit interfaces. Just for a reminder,
> here's the error:
> checkout http://anonsvn.jboss.org/repos/hibernate/core/branches/Branch_3_3/core
> -r HEAD --depth=infinity --force
>    svn: REPORT of '/repos/hibernate/!svn/vcc/default': 403 Forbidden
> (http://anonsvn.jboss.org)
> Anyway, my only workaround is that I have to check out a root (such as
> http://anonsvn.jboss.org/repos/hibernate/core/branches/Branch_3_3). If
> I go any deeper, like into the sub-project I actually want, that error
> immediately rears its ugly head.
> Paul
> On Tue, Oct 13, 2009 at 2:05 AM, Sanne Grinovero
> <sanne.grinovero at gmail.com> wrote:
>> Hi Paul,
>> I've tried checking out trunk from the anonsvn, but even wiping out my
>> suversion settings
>> it's just working: both from a terminal and from eclipse 3.5.1+subclipse which
>> is the same environment I'm working with.
>> This is what I do from commandline:
>> svn checkout http://anonsvn.jboss.org/repos/hibernate/core/trunk/core core
>> BTW the older "problem" you refer to is not a problem, the files were
>> moved and that is expected behaviour.
>> Try moving away your subversion settings (.subversion in linux), IMHO
>> there's something wrong in your settings
>> or upgrade your subversion client?
>> regards,
>> Sanne
>> 2009/10/13 Paul Benedict <pbenedict at apache.org>:
>>> Hello,
>>> I am trying to work with 3.5-SNAPSHOT but am unable to checkout trunk.
>>> When I try, I get this error:
>>> checkout http://anonsvn.jboss.org/repos/hibernate/core/trunk/core -r
>>> HEAD --depth=infinity --force
>>>    RA layer request failed
>>> svn: Server sent unexpected return value (403 Forbidden) in response
>>> to REPORT request for '/repos/hibernate/!svn/vcc/default'
>>> The error is identical to http://markmail.org/message/7shswjgpg7xwdrqc
>>> but no resolution was ever found. I am using Eclipse 3.5.1 with
>>> Subclipse.
>>> Does any committer have some spare time to try checking out from the
>>> "anonymous" url?
>>> Paul
>>> _______________________________________________
>>> hibernate-dev mailing list
>>> hibernate-dev at lists.jboss.org
>>> https://lists.jboss.org/mailman/listinfo/hibernate-dev

More information about the hibernate-dev mailing list