[hibernate-dev] [hsearch] documentation

Sanne Grinovero sanne at hibernate.org
Tue Oct 11 12:25:52 EDT 2011

On 11 October 2011 17:00, Emmanuel Bernard <emmanuel at hibernate.org> wrote:
> I see where you're coming from.
> There are two options:
> - don't care that much
> - rename default to default_for_index or index_default (or some long and annoying name like that) and deprecate default

I'm tempted for option 1) "don't care that much" as I'm not having
better ideas. Just saying that we have this issue open and it would be
nice to solve it before the next CR.

> Do you really think filter is in as much need as index for a default? Any other category that would be in need for that?

Not at all, since they are global options they don't need any
default+override, people should write it down just once anyway. They
are just examples of different categories of properties.

I'm hoping that rewriting the docs and clarifying the inconsistency we
won't need to actually change anything: it doesn't look that bad now,
I was more concerned about these when we moved around all the code and
properties actually changed "position" in the "tree" of properties.

More information about the hibernate-dev mailing list