[hibernate-issues] [Hibernate-JIRA] Created: (HHH-3411) Dead code in 3.3.0 CR1

Emeric Vernat (JIRA) noreply at atlassian.com
Fri Aug 1 09:38:00 EDT 2008


Dead code in 3.3.0 CR1
----------------------

                 Key: HHH-3411
                 URL: http://opensource.atlassian.com/projects/hibernate/browse/HHH-3411
             Project: Hibernate3
          Issue Type: Improvement
          Components: caching (L2), core
    Affects Versions: 3.3.0.CR1
         Environment: hibernate 3.3.0 CR1
            Reporter: Emeric Vernat
            Priority: Minor


I can be wrong but I found that the following package-private methods are dead code.
If they where supposed to be used there is a bug otherwise it could certainly be deleted.
They can't be used by applications as they are neither public nor protected (except by reflection which would be a hack).

getPreInval() in class org.hibernate.cache.jbc2.timestamp.ClusteredConcurrentTimestampsRegionImpl$Entry.

getLoadingCollectionXRefs() in class org.hibernate.engine.loading.LoadContexts.

afterDeserialize(...) in class org.hibernate.engine.EntityEntry, or is it called magically ?

getJoinType() in class org.hibernate.engine.JoinSequence$Join, but perhaps it should be called in JoinSequence#toJoinFragment.

getOwner() and getOwnerIdentifier() in class org.hibernate.event.def.ReattachVisitor.

process(...) in class org.hibernate.event.def.WrapVisitor.

constructor (String, List, Collection, FlushMode, boolean, SessionImplementor, ParameterMetadata) in class org.hibernate.impl.SQLQueryImpl.


For reference and future check these dead code methods were found with Dead Code Detector (http://dcd.dev.java.net)


-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://opensource.atlassian.com/projects/hibernate/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        



More information about the hibernate-issues mailing list