[hibernate-issues] [Hibernate-JIRA] Updated: (HHH-6895) Easier annotation definition of increment generator

Steve Ebersole (JIRA) noreply at atlassian.com
Tue Dec 27 13:25:19 EST 2011


     [ http://opensource.atlassian.com/projects/hibernate/browse/HHH-6895?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Steve Ebersole updated HHH-6895:
--------------------------------

    Fix Version/s:     (was: 5.0.0)
                   4.1.0
          Summary: Easier annotation definition of increment generator  (was: Easier annotation definitiopn of increment generator)

> Easier annotation definition of increment generator
> ---------------------------------------------------
>
>                 Key: HHH-6895
>                 URL: http://opensource.atlassian.com/projects/hibernate/browse/HHH-6895
>             Project: Hibernate Core
>          Issue Type: Improvement
>            Reporter: Steve Ebersole
>            Priority: Minor
>             Fix For: 4.1.0
>
>
> Useful in tests at least.  Lot of duplication to specify an increment generator currently:
> {code}
> @Id 
> @GeneratedValue( generator="increment" )
> @org.hibernate.annotations.GenericGenerator( name = "increment", strategy = "increment" )
> public Long getId() { .. }
> {code}
> Combined with the fact that the increment generator does not accept configuration, would be nice to be able to just say:
> {code}
> @Id 
> @GeneratedValue( generator="increment" )
> public Long getId() { .. }
> {code}

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        


More information about the hibernate-issues mailing list