[jboss-as7-dev] "Read" operations
Brian Stansberry
brian.stansberry at redhat.com
Thu Jan 13 17:08:17 EST 2011
Kabir,
A couple more comments re: [1] following the discussion in #jboss-as7:
1) Instead of or in addition to the READ_ATTRIBUTE_OF_TYPE op, I was
looking for something like:
{
"op" => "read-children-names",
"op-addr" => [
("profile" => "production")
],
"child-type" => "subsystem"
}
which would then return a list of the names of all subsystems.
2) Assume people are going to have to type some of these a lot, so let's
find short names for these operations:
a) public static final String READ_ATTRIBUTES_OF_TYPE_OPERATION =
"read-attributes-of-type-operation";
"read-attributes-of-type" if the behavior remains the same, else
"read-children-names"
b) public static final String READ_NAMED_ATTRIBUTE_OPERATION =
"read-named-attribute-operation";
"read-attribute"
c) public static final String READ_NODE_DESCRIPTION_OPERATION =
"read-node-description-operation";
"read-resource-description"
d) public static final String READ_OPERATION_OPERATION =
"read-operation-operation";
"read-operation-description"
e) public static final String READ_OPERATIONS_SUMMARY_OPERATION =
"read-operations-summary-operation";
"read-operation-names"
f) public static final String READ_SUB_MODEL_OPERATION =
"read-sub-model-operation";
"read"
For this last one, we could add a required=false "attribute" param, make
the existing "recursive" property required=false, and collapse b) and f)
into a single operation named "read". WDYT?
I have a desire to replace "read" with "get" in all of the above, but
that may be too many years of Java development talking.
[1]
https://github.com/kabir/jboss-as/commit/2fa26198246f0d07b0e48c95dea6728abef49d04
--
Brian Stansberry
Principal Software Engineer
JBoss by Red Hat
More information about the jboss-as7-dev
mailing list