[jboss-user] [JBoss jBPM] - Re: Web console failing

brado do-not-reply at jboss.com
Wed Jul 12 17:18:06 EDT 2006


Thanks a lot for your help. The "U" worked like a charm, and allowed me to save my record. Login also worked as a result. However, after logging in, if I try to click on the "Home" link, I get the following in the JBoss log, even though the page seems to render properly:

  | 14:12:04,515 INFO  [[/jbpm]] WARNING: Component _id13 just got an automatic id,
  | because there was no id assigned yet. If this component was created dynamically
  | (i.e. not by a JSP tag) you should assign it an explicit static id or assign it
  | the id you get from the createUniqueId from the current UIViewRoot component rig
  | ht after creation!  

Then, if I click the "Home" link a second time, the page mostly renders, except I don't seem to get the table underneath the "Start new process execution" header on the page which has the process definitions listed -- I also get the following in the JBoss log:

  | 14:14:20,906 ERROR [[jsp]] Servlet.service() for servlet jsp threw exception
  | java.lang.IllegalStateException: Client-id : _id1 is duplicated in the faces tre
  | e.
  |         at org.apache.myfaces.application.jsp.JspStateManagerImpl.checkForDuplic
  | ateIds(JspStateManagerImpl.java:241)
  |         at org.apache.myfaces.application.jsp.JspStateManagerImpl.checkForDuplic
  | ateIds(JspStateManagerImpl.java:255)
  |         at org.apache.myfaces.application.jsp.JspStateManagerImpl.saveSerialized
  | View(JspStateManagerImpl.java:204)
  |         at org.apache.myfaces.taglib.core.ViewTag.doEndTag(ViewTag.java:122)
  |         at org.apache.jsp.home_jsp._jspx_meth_f_view_0(home_jsp.java:144)
  |         at org.apache.jsp.home_jsp._jspService(home_jsp.java:76)
  |         at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:97)
  |         at javax.servlet.http.HttpServlet.service(HttpServlet.java:810)
  |         at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper
  | .java:332)
  |         at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:3
  | 14)
  |         at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:264)
  |         at javax.servlet.http.HttpServlet.service(HttpServlet.java:810)
  |         at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(Appl
  | icationFilterChain.java:252)
  |         at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationF
  | ilterChain.java:173)
  |         at org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDisp
  | atcher.java:672)
  |         at org.apache.catalina.core.ApplicationDispatcher.processRequest(Applica
  | tionDispatcher.java:463)
  |         at org.apache.catalina.core.ApplicationDispatcher.doForward(ApplicationD
  | ispatcher.java:398)
  |         at org.apache.catalina.core.ApplicationDispatcher.forward(ApplicationDis
  | patcher.java:301)
  |         at org.apache.myfaces.context.servlet.ServletExternalContextImpl.dispatc
  | h(ServletExternalContextImpl.java:415)
  |         at org.apache.myfaces.application.jsp.JspViewHandlerImpl.renderView(JspV
  | iewHandlerImpl.java:234)
  |         at org.apache.myfaces.lifecycle.LifecycleImpl.render(LifecycleImpl.java:
  | 300)
  | ...

I've tried a user ID of 1 and of 10 in the JBPM_ID_USER table, but that doesn't seem to have any effect. Anyone have any idea what the problem is?


View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=3957539#3957539

Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=3957539

More information about the jboss-user mailing list