[jboss-user] [Installation, Configuration & Deployment] - Re: IllegalArgumentException

nerbrate do-not-reply at jboss.com
Thu Nov 9 03:29:53 EST 2006


I have the same problem with jboss 4.0.4.GA and EJB3.

When I redeploy my ejb, I get:
javax.ejb.EJBException: java.lang.IllegalArgumentException: Wrong target...
when invoking any method with instances of my own classes as parameters. A restart of the server fixes the problem.

I have an EJB3 with an EJB2.1 compatible remote homeinterface (using the @RemoteHome(MyBeanHome.class) annotation). I have tried several ways to access the ejb: Through an AXIS 1.4 webservice as front, a small javaclient and using JBossWS as front. The strange thing is that all attempts fail except invoking it through the JBossWS webservice. Even after a redeploy, when all fail using the javaclient and through axis, I can still invoke all methods through JBossWS.

After I restart the server, everything works perfectly.

My Bean:

  | @WebService(
  | 		name="TestService",
  | 		serviceName="TestServiceService",
  | 		targetNamespace="http://test.myhome.org/testservice")
  | @SOAPBinding(
  | 		style=Style.DOCUMENT,
  | 		use=Use.LITERAL,
  | 		parameterStyle=ParameterStyle.WRAPPED)
  | @Stateless(name="TestService")
  | @Remote
  | @RemoteHome(TestServiceHome.class)
  | @RemoteBinding(jndiBinding = "ejb/TestService")
  | public class TestServiceSessionBean implements TestService {
  | 	@WebMethod
  |     public MyResponse myMethod(MyParameters params) {
  |     }
  | }

I have tried different versions of EJB3 with no luck (RC7 & RC9).


View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=3984430#3984430

Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=3984430

More information about the jboss-user mailing list