[jboss-user] [JCA/JBoss] - Re: Class Cast Exception when connecting to DataSource--JBos

russray do-not-reply at jboss.com
Sat Nov 18 15:37:06 EST 2006


   I think JBoss has a bug.  I have tried all three drivers for SQL Server (2005 and @00 from MS and Jtds)  In every case, I get an error.  

   The latest info is I tried JTds and get the below error:

  | 14:35:17,099 INFO  [WrapperDataSourceService] Bound ConnectionManager 'jboss.jca:service=DataSourceBinding,name=jdbc/pidbdev' to JNDI name 'java:jdbc/pidbdev'
  | 14:35:17,146 WARN  [JBossManagedConnectionPool] Throwable while attempting to get a new connection: null
  | org.jboss.resource.JBossResourceException: Could not create connection; - nested throwable: (org.jboss.resource.JBossResourceException: Could not find accessor on XADataSource: ; - nested throwable: (java.lang.NoSuchMethodException: net.sourceforge.jtds.jdbcx.JtdsDataSource.setURL(java.lang.String)))


View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=3987102#3987102

Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=3987102

More information about the jboss-user mailing list