[jboss-user] [JBoss Tools (users)] - Re: JBossTools and Eclipse 3.3.0 , does it work at all ?

davidbalazic do-not-reply at jboss.com
Thu Aug 23 05:58:42 EDT 2007

OK, I installed Eclipse freshly (unzipped eclipse-SDK-3.3-win32.zip , md5sum c7f5df655e5bd22190f31168b4f37c64), went straight to the update/install , added http://download.jboss.org/jbosstools/updates/development as new remote site, checked it and also the two other sites ("Europa Discovery Site" and "The Eclipse Project Updates") and clicked Finish.

The in the search results dialog I checked "JBossTools 2.0.0.beta3".
Immediatelly the error message "JBossTools (2.0.0.beta3) requires feature "org.eclipse.emf". popped up. I clicked on the "Select Required" button, but nothing happened. I selected the "JBossTools 2.0.0.beta3" item and clicked "Select Required" again, but nothing happened either.

Shouldn't this automatically select all dependencies for install ?

I manually checked some EMF related items, but the error was still there. As some of the items I checked also had unresolved dependencies, I clicked "Select Required" again, and not it resolved all problems. I Unchecked all except "JBossTools 2.0.0.beta3" and tried to figure out the minimum set of features required. To make it short, after I while it happened, that I had ONLY had "JBossTools 2.0.0.beta3" selected, clicked "Select Required" and now it worked and selected only 6 other features.
But not datatools.

I install them.

No errors, but I have no Deployment or Debug item.

I then install "JBossIDE JBossAS Adapter Feature". OK now I have additional items in the Preferences. JBoss Tools / JBoss Servers / View. Which causes an exception.
I then installed all datatools features, but it is the same. The error is same as described in the third post (posted at Wed Aug 22, 2007 08:40 AM)

Summary :
 - problems with dependency resolving. Eclipse or JBossTools packaging bug ?
 - features description URL should be changed to something meaningful from http://www.jboss.com/products/jbosside which just says "site moved"

View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4077228#4077228

Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=4077228

More information about the jboss-user mailing list