[jboss-user] [JBoss Seam] - Re: SeamTest Unit Tests Working...But Not Integration Tests

neilac333 do-not-reply at jboss.com
Thu Dec 13 00:28:00 EST 2007

Problem solved.  I think.  And you will never guess in a million years what the issue was.

When I started this thread, my setup was all wrong from the perspective of SeamTest.  I had an existing project, so seam-gen wasn't an option.  Once I ran into trouble though, I used it to show me what things should look like as a model for my own setup.  Eventually, I got things looking identical, yet my TestNG XML suite file would fail while the generated one would pass.  Moreover, no matter what changes I was making, I continued to fail with the same error--that NPE I began the thread with.

So it dawned on me that, at least at this point, maybe the way I was running the tests was causing the problem rather than my configuration.  Sure enough, once I removed the following from my suite file, everything worked:

  | <groups>
  |     <run>
  |         <include name="integration.test"/>
  |      </run>
  | </groups>

That's it.  Granted my configuration was messed up to start with, but all the problems I had for the last week were due to this issue.  When I put the groups element back in, I get that NPE again.

I don't know whether this is a bug or a side effect of some other configuration issue that hasn't been exposed otherwise yet.  Still, I do find it odd that something about the way TestNG runs groups causes SeamTest to fail--at least for me.

Thanks, Pete, for trying to help, and thanks to all who read the thread. 

View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4112445#4112445

Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=4112445

More information about the jboss-user mailing list