[jboss-user] [Installation, Configuration & DEPLOYMENT] - Re: exception occurs while deployingDB2JDBC driver jar

PeterJ do-not-reply at jboss.com
Thu Dec 13 17:37:58 EST 2007

I just now ran into this exact same error message using the latest JDBC4 compliant driver for PostgreSQL. Apparently, that driver was compiled using JDK 1.6 and I was attempting to run it with JDK 1.5. I find is strange that in this situation that the typical "bad version number" message does not show up, apparently one part of the code "ate" that message and forwarded the "non class file" message. You can verify if this is the case for you by looking at the manifest file in the jar, typically those are built using ant and ant will specify the JDK used to do the compile.

So the possible solutions to your problems are:

1) Try to get a copy of the driver compiled with 1.5
2) Run with the 1.6 JDK (others have tried it and it sometimes works but is not a qualified JDK for JBossAS at this time)
3) Continue to use your old driver.

View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4112748#4112748

Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=4112748

More information about the jboss-user mailing list