[jboss-user] [JBoss Seam] - Re: Seam injection doesn't work while testing with testng!

gena777 do-not-reply at jboss.com
Tue Jan 30 18:31:27 EST 2007

Ok, i don't know why, but it works now. I've tried the Seam-generated example as described on Wiki. And it did work! 

The only difference was the eclipse project kind: my project is a simple application, but seam-tutorial is an Enterprise Application. So i was missing the EAR-libraries. In my case, i got an exception within an EJB3InterseptorsInterseptor. In case of enterprise application the EE5SeamInterceptor has done it work! 

If anybody wants to know, my workaround is:
1. Create new empty EAR-Project as described in Seam-gen tutorial
2. Put references to my main project and to all jar from seam-distribution an some necessarly libs.

Testng suits run correct now.

Thanks to all guys who answered this boring posting!

View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4008562#4008562

Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=4008562

More information about the jboss-user mailing list